Descriptions

A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored cross-site scripting (XSS) when directory listing is enabled and a user views the listing.

Severity

  • CVSSv4.0 Score: 2.4 (CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N)

Affected Versions

  • armeria from 0.80.0 before 1.43.0

Fix

  • armeria should be updated to latest version (>= 1.43.0).

Reference

  • https://www.cve.org/CVERecord?id=CVE-2026-121822
  • https://github.com/line/armeria/security/advisories/GHSA-x9vf-hjgg-cq25

Updated: